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Power BI Analytics Benchmark (AB) Trainings 

Power BI - A Complete Introduction 

 
Power BI 

 
Power BI is a collection of Tools or Software’s provided by Microsoft Corporation for 

performing Business Intelligence Activities. 

Power BI is a Self Service, Cloud Based Reporting Software (OR) Data Visualization 

Software (OR) Data Analytics Software (OR) Business Intelligence Software. 

To Perform Business Intelligence there are “N” numbers of Business Intelligence 

Tools/Software’s both Traditional and Self serviced in the Market from Different Vendors, below 

are the popular among them and their service provider. 

 

BI Tool Service Provider 

Power BI Microsoft 

Tableau Tableau Software 

QlikView Qlik 

Qlik Sence Qlik 

MSBI Microsoft 

Microstrategy Microstrategy Corporation 

 

 
We have two types of BI tools in market 

1. Traditional BI 

2. Self-Serviced BI 

In recent years, we observe that there has been an evolutionary shift from legacy, on 

premise traditional Business Intelligence (BI) solutions to cloud-based, self-serviced BI. 

Traditional BI 

 
Traditional BI has been around for years and often requires a high-level technical skill 

to implement, administer and maintain the solution. Another characteristic of traditional BI is 

that it requires the solution to be housed on premise. For growing companies, this is a costly 

and ineffective solution. Additionally, since traditional BI is typically a technical product, it’s 

difficult for business users to have access to it. 

Fundamental characteristics of Traditional BI 

✓ Traditional Tools offers a broad range of features which allow companies to cover a 

wide spectrum of reporting types and an array of use cases. 
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✓ Requires a high level of technical expertise, users rely significantly on IT to perform 

even the most basic functions like building reports. As a result, user adoption rates may 

suffer. 

✓ Requires IT to have SQL query skills or learn a proprietary query language in order to 

implement- which drives up cost and adds to the time required to deploy the solution. 

Self Service BI 

Self-service BI is a form of Business Intelligence in which end users are 

empowered to independently satisfy their own information needs. With self-service BI, non- 

technical professionals can generate their own reports, run their own queries, and conduct 

their own analyses, without the assistance of IT staff. 

Fundamental characteristics of Self-Service BI 

✓ Business users are able to access the real-time data they want and quickly generate 

results without the need for technical expertise. Often, no coding skills are required. 

✓ Self Service BI’s upfront costs, total cost of ownership (TCO) and total cost of change 

(TCC) are significantly less than Traditional BI’s costs. 

✓ User adoption is typically greater with Self Service BI than with Traditional BI because 

it’s easier for the non-technical business user to understand and leverage. 

Cloud Based 

✓ Cloud-based is a term that refers to applications, services or resources made available 

to users on demand via the Internet from a cloud computing provider's servers. 

✓ With the help of Power BI Service you can analyze your data anywhere from the world 

with the help of internet. 

On-Premise BI 

✓ On-Premises BI software which is installed locally, on a company’s own computers and 

servers. 

✓ Power BI Report Server is a solution that customers deploy or install on their own 

premises for publishing, sharing and managing Reports. 

✓ Reports shared from Power BI Report Server can be accessed within the Network only. 

 
Reporting 

✓ Presenting the Data in a Structured Format we call it as Reporting. With the help of 

Power BI we can present the Data in a Structured Format hence we called Power BI 

Software as a Reporting Software. 

 
 
 
 

 

 
02



Power BI Analytics Benchmark (AB) Trainings 

Data Visualization 

✓ Presenting the Data in the form Graphs, Charts, Maps etc., we call it as Data 

Visualization (OR) Graphical Representation of Data we call as Data Visualization. With 

Power BI Software we Can Present the Data in a Graphical Format hence we call Power 

BI Software as Data Visualization Software. 

Data Analytics 

 
✓ Performing the Analysis on the Data we call it as Data Analytics. With the Help of Power 

BI Software we can perform Analysis on huge Volumes of Data hence we call Power BI 

Software as Data Analytics Software. 

Business Intelligence 

✓ Business Intelligence is a Process which Converts Business Data into Actionable 

Information. 

✓ Business Intelligence Process helps Business Managers to make more informed business 

decisions. 
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When you go as any BI Developer Clients will provide the OLTP(S) which Contains 

Business Data and ask you to perform the Analysis. It is not recommended to perform the 

Analysis Directly on top of OLTP System. As a BI Developer First we need to create an OLAP 

System where we need to bring data that is required for Analysis. To move the Data from OLTP 

Systems to OLAP System we need to use ETL Tools. Once Data is there in the OLAP we need to 

Start Performing the Analysis. Create the Reports and Visuals on Top of OLAP and Finally Share 

them with Clients. 

To Perform this Business Intelligence Activities Microsoft Provided Power BI Software. 

Power BI is the not the Name of Single Software. It’s the Name for Suite of Software’s 

which we used for performing Business Intelligence (BI) Activities. 

Power BI Software’s / Tools / Products 

o Power BI Desktop 

▪ Power Query 

▪ Power Pivot 

▪ Power View 

o Power BI Service 

o Power BI Report Server 

o Power BI Mobile 

 
Power BI Desktop 

✓ Power BI Desktop is a tool to Connect to, clean, model, and visualize your data. 

✓ With Power BI Desktop, you can connect to different Data Sources to Extract the Data, 

Transform the Data if required, Model the Data (Data Modeling) and visualize the Data 

in different ways. 

✓ Power BI Desktop is the combination of below software’s 

▪ Power Query 

▪ Power Pivot 

▪ Power View 
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Power Query 

✓ Power Query is used for Data Extraction, Transformation and Loading. It’s an ETL 

Software in Power BI. 

✓ With the help of Power Query, we will connect to the different Data Sources to Extract 

the Data, Transform the Data and then we will load the Data into Power Pivot. 

✓ The Power Query Software comes with a graphical tool “Power Query Editor” and a 

formula language M (Mashup) Language to Transform the Data. 

✓ With the help of predefined functions in the graphical tool we can transform the data 

in Power Query. However, Power Query can be programmed to create custom functions. 

This gives you seemingly unlimited potential to transform your data in just about any 

way possible. 

✓ The formula language we used in Power Query is the M (Mashup) language to create the 

custom functions. 

✓ Power Query can load the result set into Power Pivot model. 

✓ Power Query not only makes all these tasks easier, but it also records your steps. 

Power Pivot 

✓ Power Pivot is an In-Memory Columnar Database where we store the Data that is required 

for Analysis Purpose. Power Pivot is used for preparing an OLAP / Dataset. 

✓ Power Pivot is the place where we place the transformed data that is loaded by Power 

Query for Data Modeling. 

✓ Power Pivot works on xVelocity In-Memory based tabular engine. Current Name for 

Power Pivot “In Memory” is xVelocity previously they used to call as Vertipaq Engine. 

✓ The In-Memory engine gives Power Pivot super-fast response time and the modeling 

engine would provide you a great place to build relationships through Entities, build 

your Star Schema, Create New Columns, New Measures/Quick Measures and New Tables, 

and so on. 

✓ To Enhance the Data Model Power Pivot uses Data Analysis eXpression language (DAX) 

for building New Columns, New Measures/Quick Measures & New Tables. 

✓ DAX is a powerful functional language which contains multiple functions that are helpful 

to perform the Data Analysis extensively as per the Client needs by creating new 

information Like New Columns, New Measures/Quick Measures & New Tables. 

Power View 

✓ Power View is used for Data Visualization. 

✓ With Power View you can create interactive charts, graphs, maps, and other visuals that 

bring your data to life. 
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Power BI Desktop Process Flow 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
✓ Power BI Desktop as mentioned above is an editor for three components→ Power Query, 

Power Pivot, and Power View. 

✓ Power Query connects to data sources and mash up the data with a formula language, 

the result set of Power Query will be loaded into a tabular model which is Power Pivot. 

✓ Power Pivot can set the relationships and allow you to create New Columns, New 

Measures / Quick Measures and New Tables using DAX Language and set the Data Model 

as you want. 

✓ Then Power View connects to the Data Model and Visualizes the data with different 

charts and visualization elements. 

✓ Power BI Desktop has everything in one editor, and this makes it an easy to use tool. 

✓ You can solve very complex challenges with Power BI Desktop only because of its 

underlying components. 
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Power BI Service 

✓ Power BI Service is cloud based solution which is managed by Microsoft Corporation for 

publishing, sharing and managing Reports and Dashboards. 

✓ Reports or Dashboards shared from Power BI Service can be accessed anywhere from 

the world. 

✓ You can view the Reports or Dashboards that are shared with you with the help of web 

browsers or Mobile Application (Power BI Mobile). 

Power BI Report Server 

✓ Power BI Report Server is a solution that customers deploy or install on their own 

premises for publishing, sharing and managing Reports. 

✓ Reports shared from Power BI Report Server can be accessed within the Network only. 

✓ You can view the Reports that are shared with you with the help of web browsers or 

Mobile Application (Power BI Mobile). 

Power BI Mobile 

✓ Power BI Mobile is a mobile application which is used to see the Reports and dashboards 

shared with us by logging with our server credentials. 

✓ Power BI Mobile App is available for Android, Apple, and Windows Phone, simply 

download it from Google Play (Android), or App Store (Apple), or Windows Store 

(Windows Phone) and install. 

✓ After the installation login with your server credentials (username and password), and 

you’ll see Reports and Dashboards shared with you. 
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The Flow of Work in Power BI / Power BI Architecture 

A common flow of work in Power BI is 

✓ Bring data into Power BI Desktop, and create a report. 

✓ Publish to the Power BI service or Power BI Report Server, where you create new 

visualizations or build dashboards. 

✓ Share your dashboards with others, especially people who are on the go. 

✓ View and interact with shared dashboards and reports in Power BI Mobile apps 

(Windows phones and tablets, as well as for IOS and Android devices). 
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Power BI Reporting life cycle or BI Life Cycle 

✓ Preparing the data and Loading into Reporting Tool → Power Query 

✓ Data Modeling and defining Metrics → Power Pivot 

✓ Report generation → Power View 

✓ Creating Dashboards, Sharing & Admin Activities →Power BI Service or Power BI 

Report Server 

✓ Viewing Reports & Dashboards → Mobiles and Web Browsers. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
A Brief History of Power BI 

The tools in the Power BI are not new into the market. Let us see the 

history of Power BI. 

✓ Power Query is a free add-in in Excel 2010 and 2013 and it is inbuilt in Excel 2016. 

✓ Power Pivot is a free add-in in Excel 2010 and 2013 and it is inbuilt in Excel 2016. 

✓ Power View is a free add-in in Excel 2013 and it is inbuilt in Excel 2016. 

✓ Power BI Service is released on Jan 2015. 

✓ Microsoft combined Power Query, Power Pivot and Power View as Power BI Desktop 

and released on July 2015. 

✓ Power BI Report Server was released on June 2017. 
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Data Transformation with Power Query / Query Editor 

 
Data Transformation 

Data transformation is the process of converting data or information from one format to 

another, usually from the format of a source system into the required format of a new 

destination system. 

 
Data Transformation – Why? 

When existing Business model is hard to understand we use power query to Shape or 

Transform the data, and build a model that will be easily understandable for a Report User. 

If existing Business model contains too many tables and many relationships between 

tables makes a reporting query very slow and not efficient. Here we use Power Query to Shape 

and Transform the data to build a star or snow flake schema by creating dimension tables and 

fact table, which is more comfortable for report development. 

 
Transactional databases are not best option for reporting purpose because 

✓ The model is hard to understand for a Report User. 

✓ Too many tables and many relationships between tables makes a reporting query (that 

might use 20 of these tables at once) very slow and not efficient. 

✓  Also we don't need all the transactional data to be loaded into Reporting Tools we 

just load whatever data we need for reports into our reporting tools. 

 
Shape or Transform Data using Power Query 

With Power BI Desktop or Query Editor or Power Query, you can connect different types 

of data sources, and then shape the data to meet your reporting needs. 

In Power Query or Query Editor we will transform or shape the data using built-in GUI 

transformations in the ribbon or using M language code. 

 
Benefits of Data Transformation 

Data transformation ensures that data that enters your enterprise is usable and 

manageable. 

It facilitates cost-efficient storage, ease of analysis for greater business intelligence, 

and operational efficiency. 

On the flip side, storing data that has not been transformed wastes resources and 

creates the possibility of compliance risk because the data cannot be managed under the 

organization’s data governance rules. 
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Overview of Power Query / Query Editor 

✓ Power Query is a Data Extraction, Transformation and Loading Engine. 

✓ The Engine comes with a Graphical Tool and a Formula Language (M Language). 

✓ Power Query can connect to set of data sources and read data from them for data 

preparation. 

✓ Once connected to any data source, then Queries (one for each table, or entity) are 

listed and available for selection, viewing, and shaping. 

✓ The Graphical Tool has list of Transformations that can be applied on a data set or 

Queries, and it also supports different data sources. 

✓ Power Query graphical interface is so easy to work with that even business analyst or 

a power user can work with it, on the other hand Power Query M language is so powerful 

that can be used for complex real world challenges of data transformations. 

✓ However, the Power Query formula language (M Language) is much more powerful than 

the GUI. Actually there are some features in Power Query engine that not yet has been 

implemented through GUI, but they are available through M Language. 

✓ Power Query can load the result set into Power Pivot for data modeling. 

✓ M is the formula language behind the scenes of Power Query. Everything you do in the 

Query Editor will be translated to an M script. M contains full list of functions that you 

can use. So the powerful side of Power Query is actually M. M is a functional language 

and it has a simple structure. 

✓ Every data preparation steps or applied steps on Queries will be recorded and displayed 

in Query Editor under Applied Steps Section. 

 
Query Editor User Interface 

You can open Power Query Editor in three different ways 

1. From Home Tab you can find Edit Queries. 

2. In the Table Level Options you can find Edit Query. 

3. While loading the table edit option that takes you to the Edit Queries. 

To get into Query Editor, select Edit Queries from the Home tab of Power BI Desktop. 
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Other way to get or open Query Editor is, go to Table Level Options you can find Edit Query. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Third way is while loading the table “Edit” option that takes you to the Edit Queries. 
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With no data connections, Query Editor appears as a blank pane, ready for data as 

shown below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
How to establish connection to the source? 

Home Tab →New Source → Get Data window→Select the Source Type → Select the 

Source → Ok 

Once Query Editor is loaded with data that's ready for you to shape, you see a handful of 

sections. Here’s how Query Editor appears once a data connection is established. 
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1.  In the ribbon, many buttons are now active to interact with the data in the query for data 

preparation. 

2.  In the left pane or queries pane, queries (one for each table, or entity) are listed and 

available for selection, viewing, and shaping. 

3.  In the center pane or Results Pane, data from the selected query is displayed and 

available for shaping. 

4. The Query Settings window appears, listing the query’s properties and applied steps. 

5.  The Formula bar is the place where you can see and edit the M code of the current 

transformation step. 

We’ll look at each of these four areas 

✓ The ribbon 

✓ The queries pane 

✓ The data view / Results Pane 

✓ The Query Settings pane 

✓ Formula Bar 

The Query Ribbon 

The ribbon in Query Editor consists of four tabs – Home, Transform, Add Column, and 

View. 

Home Tab 

The Home tab contains the common query tasks, including the first step in any query, 

which is Get Data. The following image shows the Home ribbon. 

 
 
 
 
 
 
 

 
Transform Tab 

The Transform tab provides access to common data transformation tasks, such as adding 

or removing columns, changing data types, splitting columns, and other data-driven tasks. The 

following image shows the Transform tab. 
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Add Column Tab 

The Add Column tab provides additional tasks associated with adding a column, 

formatting column data, and adding custom columns. The following image shows the Add 

Column tab. 

 
 
 
 
 
 
 
 
 
 

 
The Difference between the Transform and Add Column Tabs 

The bulk of all transformations available in power query can be accessed through either 

the Transform tab or the Add Column tab. 

You might think there is a lot of duplication between these two tabs. For example, both 

tabs contain a form Text section with a lot of the same commands. It’s not really the case, 

there is a subtle difference! 

When you use a command from the Add Column tab that is found in both tabs, it will 

create a new column with the transformed data and the original column will stay intact. 

Whereas using the equivalent command from the Transform tab will change the original column 

and no new column is created. This is a critical point to be aware of! 

View Tab 

The View tab on the ribbon is used to toggle whether certain panes or windows are 

displayed. It’s also used to display the Advanced Editor. The following image shows the View 

tab. 

 
 
 
 
 
 
 
 
 
 

 
It’s useful to know that many of the tasks available from the ribbon are also available 

by right-clicking a column, or other data, in the center pane. 
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The Left Pane / Queries Pane 

The left pane displays the number of active queries, as well as the name of the query. 

When you select a query from the left pane, its data is displayed in the center pane, where you 

can shape and transform the data to meet your needs. The following image shows the left pane 

with multiple queries. 

 
 
 
 
 
 
 
 
 
 
 
 

 
The Center (Data) Pane / Results Pane 

In the center pane, or Data pane, data from the selected query is displayed. This is 

where much of the work of the Query view is accomplished. 

Notice that many of these right-click menu items are the same as buttons in the ribbon tabs. 

When you select a right-click menu item (or a ribbon button), Query applies the step to 

the data, and saves it as part of the query itself. The steps are recorded in the Query Settings 

pane in sequential order, as described in the next section. 

The Query Settings Pane 

The Query Settings pane is where all steps associated with a query are displayed. For 

example, in the following image, the Applied Steps section of the Query Settings pane reflects 

the fact that we just changed the type of the Overall score column. 
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As additional shaping steps are applied to the query, they are captured in the Applied 

Steps section. 

It’s important to know that the underlying data is not changed rather Query Editor 

adjusts and shapes its view of the data, and any interaction with the underlying data occurs 

based on Query Editor’s shaped and modified view of that data. 

In the Query Settings pane, you can rename steps, delete steps, or reorder the steps as 

you see fit. To do so, right-click the step in the Applied Steps section, and choose from the 

menu that appears. All query steps are carried out in the order they appear in the Applied Steps 

pane. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Formula Bar 

This is where you can see and edit the M code of the current transformation step. Each 

transformation you make on your data is recorded and appears as a step in the applied steps 

area. 
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The Advanced Editor 

If you want to see the code that Query Editor is creating with each step, or want to 

create your own shaping code, you can use the Advanced Editor. To launch the advanced editor, 

select View from the ribbon, then select Advanced Editor. 

 
 
 
 
 
 
 
 
 
 
 
 

 
A window appears, showing the existing Query code. You can directly edit the code in 

the Advanced Editor window. To close the window, select the done or Cancel button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Saving Your Work 

When your query is where you want it, you can have Query Editor apply the changes to the 

data model into Power BI Desktop, and close Query Editor. To do that, select Close & Apply 

from Query Editor's File menu as shown below. 
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Once you have your query where you want it, or if you just want to make sure your 

work is saved, Power BI Desktop can save your work in the form of “. pbix” file. 

To save your work, select File > Save (or File > Save As), as shown in the following image. 
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In below diagram you can see a high level diagram of Power Query conceptually 
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Data Type 

Change Data Type of a Column in Power BI 

When you import or load a table from any data source, Power BI will automatically 

detect the data type of a column. However, there may be some situations where Power BI might 

get them wrong. For example, it may consider amounts, values, or even dates as the text. Now 

we will see how to Change Data Types of a Column in Power BI with example. Changing data 

type of the column is important as DAX functions have special data type requirements and also 

filtering options will change based on data type of the column. 

In Query Editor or Power Query you can change the Data Type of a column in different 

ways. 

Approach 1 

In the below image for Units Sold Column, Power BI identified it as string column. But 

actually we have Decimal Numbers as that column values. 

 
 
 
 
 
 
 
 
 
 
 
 

 
So to change the data type, select the Column for which you want to change the data 

type. Next, click on the left corner of the column header which is marked in Red Box. Then 

select the data type which is appropriate, here Decimal Number. 

Changing data type of a column will open the following pop up window. You can Choose 

“Replace Current” to update current step or also you can choose “Add new step” to add a new 

transformation step to the Query. 
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Approach 2 

Select the Column name that you want to alter the data type, and click on the Data 

Type button under the Home tab in Power Query Ribbon. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Approach 3 

Select the Column that you want to change the data type and right-click on it will open 

the context menu. Select the Change Type and then select the data type from the list. For now, 

we are selecting the Decimal Number. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Filtering select Rows in Power Query / Filters in Power Query 

Data Type of column has impact on filtering options available. Filter options changes 

with respect to data types. Before going to filter rows check the data types of the columns. 

“Text Filtering Options Are Case Sensitive”. 
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Filter a column using an Auto Filter / Basic Filtering 

✓ Select the column that you need to filter. 

✓ Click the down arrow ( ). 

✓ Uncheck the Select All box to deselect all Column Values. 

✓ Select the column values you want to include in your table. 

✓ Click OK. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
“Search Bar is Case Insensitive”. 

Note: 

 
Be careful if you are filtering the rows using Search Bar. Always look at the M code return 

by Power Query and cross check it is filtering as expected. 

Basic Filtering is good only if you want to do equity filtering for values that exists in the 

current data set, however it won’t work correctly if you want to check ranges, or contains or 

things that is not an exact equity filter. Advanced Filtering is the correct way of filtering in 

Power Query, and there are advanced filters for all types of data types; Numbers, Text, 

Date… 
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When you filter a column, only the top 1,000 distinct values in the column will load into 

the filter list. If there are 1,000 or more values in the column in Query Editor that you are 

filtering, a message will appears indicating that the list of values in the filter list may be 

incomplete, and the Load more link is shown. Click the Load more link to load another 1,000 

distinct values. 

If exactly 1,000 distinct values are found again, the list is displayed with a message 

stating that the list could still be incomplete. 

If less than 1,000 distinct values are found, the full list of values is shown. 

Filter a Column using Text Filters 

In addition to the “Auto Filters” or Basic Filtering, you can filter a Text values using the 

Text Filters context menu. 

Click the down arrow ( ) of the column containing a Text values you want to filter on. 

Click Text Filters and select the filter option required from Context Menu. 
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Filter a Column using Number Filters 

In addition to the “Auto Filters”, you can filter Number values using the Number 

Filters Context Menu. 

To filter a column using Number Filters, Click the down arrow ( ) of the column 

containing a Number values you want to filter on. 

Click Number Filters, and select the filter option required from Context Menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Filter a Column using Date Filters 

In addition to the “Auto Filters”, you can filter Date values using the Date 

Filters Context Menu. 

To filter a column values using Date Filters, Click the down arrow ( ) of the column 

containing Date values you want to filter on. 

Click Date Filters, and select the filter option required from Context Menu. 
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Filter Multiple Columns 

To filter multiple columns, select an additional column, and repeat one of the column 

filter steps. AND Operation will be performed between the columns if you apply filters on 

multiple columns individually. 

Other way is by Using Advanced option in Filter Rows you can apply filters on multiple 

columns at a time. Here you can select And / Or operation between columns. 
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In below image we applied filters on Row ID and Customer Name Column and you can 

see M Language Code. 
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Inbuilt Column Transformations 

✓ Remove Columns / Remove Other Columns 

✓ Name / Rename a Column 

✓ Reorder Columns or Sort Columns 

✓ Add Column / Custom Column 

✓ Split Columns 

✓ Merge Columns 

✓ Pivot, Unpivot Columns 

✓ Transpose Columns 

 
Remove Columns / Remove Other Columns 

If you want to remove unwanted columns which are not necessary in your data model 

for the data source in your query, you can use Remove Columns / Remove Other Columns option 

as shown in the below image. 

If you want remove selected columns 

Select the columns you want to remove → Right Click → Remove Columns 

If you want to remove all other columns other than selected 

Select the columns you want to keep → Right Click → Remove Other Columns 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
You can also remove columns from Manage Columns Section in Home Tab in Query 

Editor Ribbon. 
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